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Installation



e Installation via app/code: Upload the content of the module to your root folder. This
will not overwrite the existing Magento folder or files, only the new contents will be added.
After the successful upload of the package, run below commands on Magento 2 root
directory.

php bin/magento setup:upgrade
php bin/magento setup:di:compile

php bin/magento setup:static-content:deploy

e Installation via Composer: Please follow the guide provided in the below link to
complete the installation via composer.

https://docs.scommerce-mage.com/magento-2-extensions/installation-via-

composer/installation-via-composer

Configuration Settings for Product Shelf
Life Expiration

Go to Admin > Stores > Configuration > Scommerce Configuration > Product Shelf Life
Expiration

General Settings

e Enabled - Select "Yes" or "No" to enable or disable the module.
e License Key -Please add the license for the extension which is provided in the order
confirmation email. Please note license keys are site URL specific. If you require license

keys for dev/staging sites then please email us at support@scommerce-mage.com.

General Settings

w

Enabled .. . .| Select"Yes"to enable the
module

This setting will be used to enable or dizable module

License K&y | 5.5 05kwBNI72W.RXLDS|gstgNBUERUBIVDra185ave: < ENtEr the license key for the
o module
This semting will be used to verify your license key for the give
damain
M.B. License keys sre domain specific so lor your testing or staging sives
please email us at core@rcommerce-mage com
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Batch Settings

o Batch expiry email notification period (hnumber of days) - Please define batch
expiry email notification period. This setting will check the batch expiry date and will send
an email notification to the admin for the same.

o Batch expiry email notification (Yes/No) - Please select "Yes" or "No" to "Enable" or
"Disable" the email notification regarding batch expiration.

e Disable batch once expired - Please select "Yes" or "No" to disable the batch. It
disables the batch automatically once their expiry date is passed and runs as part of cron
job at midnight.

e Email Addresses - Please provide email addresses (comma separated) to send the batch
expiration email notification.

e Email Sender - Please select sender/ from email addresses for Batch expiry updated.

e Select Email Template -Please select the email template for batch expiry email
notification.

e Cron Scheduler for expiry batch notification - This setting will be used to send the
email through the cron.

o Batch Selection Attribute - This setting will determine how batches are selected
automatically.

e Batch Selection Attribute Direction - As per the batch selection attribute you can
choose the direction for example Ascending(ASC) or Descending(DSC).

e Batch Selection - You can choose to select batches automatically based on batch
selection attribute or you can set it to Manual. When Manual you will be able to select
batches during shipment.



Batch Settings
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Product Batches Grid

You can create and manage product batches from, Admin> Product Batches. This grid will have
all the details about batches like ID, Batch Code, Product SKU, Batch Status, Batch Qty, Batch
Expiry, Action/Edit and Source Inventory.
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Product Batches Add New Batch

Y Filters WX, Export v G Defaultview v R e 3
26 records found 30 ¥ | perpage < 1
g3 Batch Code Product Sku Batch Status T | Batch Qty Batch Expiry Action | Source Inventory
125 Testd N/A Enable 20 2020-01-29 Edit newtest
132 j2 N/A Enable 10 2020-01-25 Edit us
138 dz /A Enable 15 2020-01-26 Edit default
139 T1 N/A Enable 10 2020-01-27 Edit test

e Add Sources at Product Level -You can add product source from Admin > Catalog >
Select Products > Click "Assign Sources"> Select "Source"> Click "Done" .

Sources
Advanced Inventory
Assigned Sources Name Source Status Source Item Status Qty * Notify Qty

Default Enabled In Stock A 100

¥| Use Default

us Enabled In Stock A 10

¥| Use Default

e Add New Product Batch -To create new product batch, go to Admin > Product
Batches>click '"Add New Batch'. It will take you to the new product batch page and by
providing all the required details; you can create the new batch.
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New Product Batch

Add Product Batch

Add batch code/number. This should be a unigue code,

Batch Code/Number *

Batch Quantity =* ‘ ‘
Add the batch quantity.

Source Inventory #* ‘ Default Source v

Choose source inventory for this batch,

Batch Status | Enable ‘ - |

This setting will enable/disable the batch.

Batch Expiry #* ‘ |
Add the batch expiry date.

Associate Product Sku ‘ |

This batch has been assigned to the product SKU:

e Un-Associate / Delete Product Batch -Toun-associate and delete product batch, go to
Admin > Product Batches> Select Batch > Edit >Click "Un-Associate with
Product' and for Delete click on "Delete" button.
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Edit Product Batch

Batch Code/Number = | TestBatchiew 0001

Add batch code/number. This should be a unigue code.

Batch Quantity * | 10
Add the batch guantity.

Source Inventory #* | Default Source | v ‘

Choose source inventory for this batch.

Batch Status | Enable | v ‘

This setting will enable/disable the batch.

Batch Expiry = | 4/9/21 -
Add the batch expiry date.

Associate Product Sku | M]01-X5-Orange

This batch has been a55igned-t3the pmdﬂct SKU: MJ01-X5-0

Product Batches at Product Level

When user enables the module then Product Batches section appears at,
Admin>Catalog>Product>Select Product>Edit>Product Batches. From this section, users
can add new batch or can associate specific existing batch to a product.

Product Batches @
Batches

Please use Add Specific Batch to associate batches (grid) to the current product. Add Specific Batch

< w3

ions

HIREF) 2 20200125 o us Remove

# 138 d2 2020-01-26 default Remove

Add Specific Batch to Product

You can also add specific batches to a product from, Admin > Catalog > Product > Select
Product >Edit >Product Batches >Click"Add Specific Batch". It redirects to Batch Grid and
by selecting batch ID you can associate active batches to a product.
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Cancel Add Selected Batches

2 records found (3 selected) 20 ¥ | per page < 1
- |~ [l | | Batch Code Source Inventory Batch Qty Batch Status Batch Expiry

132 j2 us 10 Enable 2020-01-25

138 d2 default 15 Enable 2020-01-26

e Select Batches During Shipment -To select the batch during shipment make sure
Batch Selection is set to manual in the configuration then navigate to Admin> Sales >
Order > Select Order > View>Generate Invoice>Click on Ship. When you scroll
down on the page you will see the option to select the batches manually. The product
quantity will be deducted from the selected batch. Please refer to the image below:-

Batch Code - Expiry Date - Total Qty Quantity Action
Shelf_02 - 2021-02-12 - 600 v 100 i"
Shelf_02 - 2021-02-12 - 600 v l 200| 3 .

Add New Row

e Batch Details on the Order View Page -To view theproduct batch related details, go to
Admin > Sales > Order > Select Order > View.

ltems Ordered

Item Original
Product Status Price Price Qty

|oust Duffle Shipped $45.00 $45.00 Ordered 15
Bag Invoiced 15
SKLU: 24-MBO1 Shipped 15

Batch
Details

Code:
LkBatchl

Quantity: 10

Expiry: 2020-
01-28

Source: UK
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Deleting or Un- Associating a Product Batch

e Deleting: -To delete a product batch, go to Catalog>Product Batches then select the
product batch that you want to delete. From Action coloumn click Edit. Here you will see
the option to delete the Product batch.

Note:- If an order has been shipped then you won't be able
to delete that product batch. You will see an error.

& Back Un-Associate with Prod

Edit Product Batch

Batch Code/Number *

Add batch code/number. This should be a unique code.

Batch Quantity * | O
Add the batch quantity,

Source Inventory * | Default Source b

Choose source inventory for this batch.

Batch Status Enable -

This setting will enable/disable the batch.

Batch Expiry * | 2/3/21
Add the batch expiry date.

Associate Product Sku P
This batch has been assigned to the product SKU: TestSimpleA_1

e Un-Associating:- To Un-Associate a product batch, go to Catalog>Product Batches then
select the product batch that you want to delete. From Action column click Edit. Here you
will see the option to Un-Associate the Product batch.

€ Back Delete Un-Associate with Product m

Edit Product Batch

Batch Code/Number + 7

Add batch code/number. This should be a unique code.

Batch Quantity * | 0
Add the batch quantity.

Source Inventory * | Default Source v
Choose source inventary for this batch.

Batch Status Enable -

This setting will enable/disable the batch.

Batch Expiry * | 2/3/21
Add the batch expiry date,

Associate Product Sku
This batch has been assigned to the product SKU: Testsimplea_1
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Note:- If an order has been shipped then you won't be able
to delete that product batch. You will see an error.

e Batch Report:- To view the detailed batch report go to your admin panel then
Reports>Sales>Batches. Here you can see all the orders associated with a product
batch with the following information:-

e Order Number

e Purchase Date

e Customer

e Customer Group

e Product Name

e Batch code

e Batch Quantity

e Expiry Date

Batch Report Q M L oeshentsngh +

StorevView:  Alwebsies » (@)

Exportto: | CSV v Export
Reset Filter 240 records found 20 ¥ | perpage < 1 of 12 >
Order Numbar Purchase Date r Customer Group Batch Code Batch Qty

From Fror it From From

To To To To
000000024 Aug 14, 2020, 12:42:30 PM Shelf Life General Joust Duffle Bag testBatchMainDefault_01 5 Aug 21, 2020
000000035 Aug 14, 2020, 1:08:58 FM Shelf Life General Joust Duffle Bag testBatchMainDefauit_01 10 Aug 21, 2020
000000035 Aug 14, 2020, 1:08:58 PM Shelf Life Genaral Joust Duffle Bag testBatchMainDefault 02 5 Aug 22, 2020
000000035 Aug 14, 2020, 1:08:58 PM Shelf Life General Joust Duffle Bag test_BarchMainDefault_03 0 Aug 24, 2020
4000000012 Aug 14,2020, 1:17:16 PM Shelf Life Genaral Joust Duffle Bag testBatchMainDefault 01 10 Aug 21, 2020
4000000012 Aug 14, 2020, 1:17:16 FM Shelf Life General Joust Duffle Bag testBatchMainDefault_02 5 Aug 22, 2020
4000000012 Aug 14,2020, 1:17:16 PM Shelf Life Genaral Joust Duffle Bag test_BatchMainDefault_03 0 Aug 24, 2020
000000036 Aug 14, 2020, 1:38:54 PM Shelf Life General Joust Duffle Bag testBarchMainDefault_01 10 Aug 21, 2020
000000026 Aug 14,2020, 1:38:54 PM Shelf Life General Joust Duffle Bag testaatchMainDefault 02 5 Aug 22, 2020
000000036 Aug 14, 2020, 1:38:54 PM Shelf Life General Joust Duffle Bag test_BatchMainDefaukt_03 L] Aug 24, 2020

Import / Export Product Batches

To import and export product batches, go to Admin > System >Import / Export.

e Import - It updates the stock quantity and disables the batches if they are expired.
o Export-It exports the batches in the selected file format, e.g. CSV.

Import Settings


https://docs.scommerce-mage.com/uploads/images/gallery/2025-05/H8Vimage-35-1.png

Import

© Make sure your file isn't more than 768M.

Import Settings

Entity Type

Import Behavior

Import Behavior

Allowed Errors Count

Field separator

Multiple value separator

Empty attribute value constant

Fields enclosure

File to Import

Select File to Import

Images File Directory

*

%

Product Batches Import ¥ |Download Sample File
- Please Select—- | = | 0

Stop on Error v

10

Please specify number of errors to halt import process

_ EMPTY_VALUE

Choose File | No file chosen

File must be saved in UTF-8 encoding for proper import

For Type "Local Server” use relative path to Magento installation, e.g. var/fexport, varfimport,
variexport/some/dir

CSV File Format for Import - CSV file will have batch_code, batch_qty, batch_status,
batch_expiry, product_sku and source_inventory.


https://docs.scommerce-mage.com/uploads/images/gallery/2025-05/image-56.jpg

A B C D E F

batch_code batch gty batch_status batch_expiry product sku Source inventory
batch_codel 1 1 15-09-2019 24-MBO1 UK
batch_code2 1 1 15-09-2015 24-MBO1 us
batch_code3 1 1 15-09-2015 24-MBO3 Uk

Export Settings
D L productshelfife +

Export Settings

Entity Type Export Product Shelflife | =
Export File Format csv -

Fields Enclosure

Entity Attributes

Reset Filter 0 records found

Exclude Attribute Label Attribute Code L | Filter

We couldn't find any records.

Continue

e Batch Expiration Email Notification - When you select "Yes" for "Batch expiry email
notification"from Admin > Stores > Configuration > Scommerce Configuration >
Product Shelf Life Expiration > Batch Settings, then it sends an email notification for
batch expiration.
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Shelf Life Expiration Notification © imp x

Sales <szles@example.com=
tome =

O Luma

Dear Admin,

Below are the batches expiring in next 6 days

4:31 PM (5 hours ago)

Code

New Batch

batch12

test_coded

batch_code2

batch_code3

newkz2

newP2

batch_code

New Batch |1

testPB

batch_coded

batch_code5

Quantity

£

10

16

Expiry Date

2019-09-28

2019-09-24

2019-09-25

2019-09-29

2019-09-29

2019-09-25

2019-09-25

2019-09-29

2019-09-27

2019-09-25

2019-09-29

2019-09-29

Associated product sku

N/A

24-MBO6

N/A

24-MBO1

24-MB0O3

24-MB05

24-WB06

24-MBO1

24-MBO1

24-MB0O3

24-MB0O3

24-MB0O3

Thanks

APl - Application Programming Interface

Authentication Token

auth_token can be received using the following: -

You would need credentials to your store with admin rights Parameters:-.Admin

credentials

e Username
e Password

'
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POST URL:- http://baseurl/index.php/rest/V1/integration/admin/token Content-Type:
application/json

"username": "admin", "password": "admin"

Creating a Batch using API

Parameters:-

e Authorization token received from the above step
e Batch code

Batch quantity

Batch status

Batch expiry

Product SKU

POSTURL:-http://baseurl/index.php/rest/V1/productbatches/createbatch Content-Type:
application/json

Authorization: Bearer {{auth_token}}

{

"batch_code": "batchcode 001", "batch_qty": "10",
"batch_status": "1",

"batch_expiry": "2020-12-06", "product_sku": "MHO0001"

}

Retrieve all Batches using API

Parameters:-

Authorization token

GET URL:-http://baseurl/index.php/rest/V1/productbatches/getcollection Content-Type:
application/json

Authorization: Bearer {{auth_token}}


http://baseurl/index.php/rest/V1/integration/admin/token
http://baseurl/index.php/rest/V1/productbatches/createbatch
http://baseurl/index.php/rest/V1/productbatches/getcollection

Retrieve Date of Batch using ID 1 Using API: -

Parameters: -

e Authorization token
e Batch ID in URL

GET URL:-http://baseurl/index.php/rest/V1/productbatches/getbatch?batchld=1 Content-Type:
application/json

Authorization: Bearer {{auth_token}}

Delete Batch with ID 1 Using API: -

Parameters: -

e Authorization token
e Batch ID

PUT URL: - http://baseurl/index.php/rest/V1/productbatches/deletebatch Content-Type:
application/json

Authorization: Bearer {{auth_token}}

{

"batchld": 1

If you have a question related to this extension please check out our FAQ Section first. If you can't

find the answer you are looking for then please contact support@scommerce-mage.com.
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